Home > EIGRP over Frame Relay and EIGRP Redistribute Lab

EIGRP over Frame Relay and EIGRP Redistribute Lab

April 29th, 2013 in Guide Go to comments

In the previous Frame Relay Point-to-Point Subinterface lab we have set up Layer 2 connection via Frame Relay but only adjacent routers can ping each other. For example R1 can ping R2 and R2 and ping R3 but R1 cannot ping R3. This is because R2 connects with R1 and R3 via point-to-point interfaces and they use separate subnets. In this lab we will use EIGRP to advertise these routes so that “remote” routers can ping each other.

topology.jpg

IOS used in this lab: c3640-jk9s-mz.124-16.bin

Tasks for this lab:
+ Configure EIGRP so that R1, R2, R3 and R4 can see and ping each other
+ Configure default route on R1 to 209.65.200.226 of R6
+ Advertise that default route to other routers via EIGRP so that every router can go to the Internet

Configure EIGRP on R1, R2, R3 and R4

R1
router eigrp 16
network 172.16.0.0
R2
router eigrp 16
network 172.16.1.0 0.0.0.255
R3
router eigrp 16
network 172.16.1.4 0.0.0.3
network 172.16.1.9 0.0.0.0
R4
router eigrp 16
network 172.16.1.0 0.0.0.25

The configuration of EIGRP is simple but please keep in mind that the “network” command really doesn’t advertise the network in that command. It enables EIGRP on the interface matched by the “network” command. For example, on R2 the “network 172.16.1.0 0.0.0.255” command instructs R2 to search all of its active interfaces (including subinterfaces) and R2 finds out the IP addresses of s0/0.12 and s0/0.23 subinterfaces belong to “172.16.10 0.0.0.255” network so R2 enables EIGRP on these subinterfaces. Another example is on R3, the “network 172.16.1.4 0.0.03” will enable EIGRP on s0/0.23 subinterface only. Without the “network 172.16.1.9 0.0.0.0” command, EIGRP would not be enabled on s0/0.34 subinterface. You can verify which interfaces are running EIGRP by the show ip eigrp interfaces command.

So any mask you put in your network command, as long as it matches or includes the IP address on a particular interface than you are good to go. And if you are lazy, just put the “network 0.0.0.0 255.255.255.255” command on each router, this will tell that router “enable EIGRP on all of my active interfaces (regardless what their IP addresses), please” because the wildcard 255.255.255.255 indicates that the router does not care about what network is using.

Note: The “network” command also works in the same way for OSPF, RIP and other Interior Gateway Protocol (IGP) routing protocols, except for BGP (which is an EGP routing protocol). In BGP, the function of a network statement is to tell the router to search the IP routing table for a particular network, and if that network is found, originate it into the BGP database.

After typing the configuration above we can ping remote routers now. For example the ping from R1 to R4 will be successful.

R1_ping172.16.1.10.jpg

And the routing table of R1 contains all networks in this topology:

R1_show_ip_route.jpg

Other routers’ routing tables are the same so I will not post them here.

Redistribute static route into EIGRP

In this part we will learn how default route to Internet (or to ISP router) should be advertised. Suppose R6 in the topology is the ISP router.

ISP_topology.jpg

R1
interface s0/1
ip address 209.65.200.225 255.255.255.252
no shutdown
R6
interface s0/0
ip address 209.65.200.226 255.255.255.252
no shutdown
!
interface Loopback0
ip address 209.65.200.241 255.255.255.252
!
//Static route to make sure R6 can reply to other routers
ip route 172.16.0.0 255.255.0.0 209.65.200.225

You can’t run an IGP routing protocol (like OSPF, EIGRP) on the ISP router so the most simple way to send traffic to the ISP router is to use static route. So on R1 we will set up a static route to R6, we can do it via 3 ways:

R1(config)#ip route 0.0.0.0 0.0.0.0 s0/1

or

R1(config)#ip route 0.0.0.0 0.0.0.0 209.65.200.226

or

R1(config)#ip route 0.0.0.0 0.0.0.0 s0/1 209.65.200.226

Note: Just for your information about static route, the paragraph below is quoted from http://www.cisco.com/en/US/docs/security/asa/asa82/configuration/guide/route_static.html.

“Static routes remain in the routing table even if the specified gateway becomes unavailable. If the specified gateway becomes unavailable, you need to remove the static route from the routing table manually. However, static routes are removed from the routing table if the specified interface goes down, and are reinstated when the interface comes back up”.

I want to notice that in all three cases of the ip route statements above, the static route will be removed in the routing table when s0/1 of R1 or s0/0 of R6 goes down. In other word, if you point a static route to a broadcast interface, the route is inserted into the routing table only when the broadcast interface is up.

As you see the third case use both the local outgoing interface and the next-hop IP address. In fact in the topology above it has no more effect than the second case (only use next-hop IP address). The third case is only better in the case the remote interface goes down and next-hop IP can be reachable through a recursive route (but I haven’t test it).

For more information about “ip route” command, please read the following link: http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800ef7b2.shtml

Ok, now R1 knows where to throw the packets when it can’t find a suitable destination for them. The routing table of R1 now shows the default route to 209.65.200.226. Notice that by default, static routes have an Administrative Distance of 1.

R1_show_ip_route_added_static_route.jpg

But R2, R3 and R4 still do not know! We can configure a static route on each of them but it is not a good thing to do. A better way to advertise this static route to R2, R3 and R4 is via the configured EIGRP. How can we do that? Ahh, we will redistribute this static route into EIGRP and EIGRP will advertise it for us. On R1:

router eigrp 16
redistribute static metric 64 100 100 100 1500

Note: The ip route command is not automatically carried in routing updates like the ip default-network command (in some routing protocols). You must redistribute the static command into a routing protocol for it to be carried.

The 5 parameters are used for redistribution into EIGRP are Bandwidth, Delay, Reliability, Load, MTU. For example the redistribution above is corresponding to Bandwidth = 64Kbit, Delay = 1000ms, Reliability=100, Load=100, MTU=1500 bytes. Notice that the unit of Delay used in the redistribution into EIGRP is tens of microsecond so we must divide Delay (in millisecond) by 10.

Now the routing tables of other routers (than R1) also learn this default route as an EIGRP external route (marked with D*EX). For example the routing table of R2:

R2_show_ip_route_after_redistribute.jpg

The default administrative distance for EIGRP externals (routes redistributed into EIGRP) is 170.

By default, K1 = 1, K2 = 0, K3 = 1, K4 = 0, K5 = 0 so the metric formula for EIGRP is:

metric = (107 / Slowest Bandwidth of all interfaces[Kbit] + Sum of delay[ten-of-millisecond] ) * 256

You can check the total delay and minimum bandwidth used to calculate EIGRP metric via the “show ip route <route>” command:

R2_show_ip_route_0.0.0.0.jpg

Therefore the EIGRP metric here should be:

metric = (107 / 64 + 2100) * 256 = 40537600

Note: We are not sure why the unit of delay here is microsecond. But if we consider “microsecond” millisecond we will get the correct metric, otherwise we never get the correct result. And the unit of sum of delay used to calculate EIGRP metric is ten-of-millisecond so we have to divide the total delay by 10 (21000 / 10 = 2100).

We can verify R4 has learned the default route, too:

R4_show_ip_route_after_redistribute.jpg

R4 also knows it has to route unknown traffic to 172.16.1.9. Also notice 172.16.1.9 now becomes the “gateway of last resort” of R4.

The GNS3 initial and final configs can be downloaded here:

Initial Configs: http://www.networktut.com/download/EIGRP_over_Frame_Relay_TSHOOT_Demo_initial.zip
Final Configs: http://www.networktut.com/download/EIGRP_over_Frame_Relay_TSHOOT_Demo_finalConfigs.zip

Next recommended reading: VLAN Routing

Comments (30) Comments
  1. Sherif
    May 16th, 2013

    pls can anybody tell me how the questions will look like is it going to come with the diagram or just as it is on this ticket. pls reply to labite80@yahoo.com> thank you all

  2. ccnp
    September 30th, 2013

    please can some help me and send me link for downlod ios c3640-jk9s-mz.124-16.bino

    I want to test labs

  3. Maurice
    November 21st, 2013

    Thank you sooo much for these two Frame relay labs. Now my goal is to do them repetitively so it becomes second nature. i honestly forgot I needed redistribute the static into EIGRP to access the external network. Thanks!!

  4. Dovinant
    December 4th, 2013

    It’s ok. But we can’t reach any subnets belonging R6. To do so we have to type something like that on R6:

    ip route 0.0.0.0 0.0.0.0 209.65.200.225

  5. Dovinant
    December 4th, 2013

    Damn!

    ip route 172.16.0.0 255.255.0.0 209.65.200.225 Of course!

  6. Anonymous
    February 5th, 2014

    what the loobback for on r6

  7. Renolph
    February 11th, 2014

    @ networktut,why cannot I ping the ip address of the ISP router but I can ping the PE router,is it because the internet does not allow private address or what?

  8. fgb
    March 26th, 2014

    pls guys, how do i find jeremy’s tshoot vedios?

  9. sami
    April 25th, 2014

    hi all
    subscribe to that channel http://www.youtube.com/user/Joynetworks for free

    thanks

  10. VomitosArcaz
    May 22nd, 2014

    Hi mates!!

    I want to prepare this exam and I have this dumps:

    -Cisco.Exact-Exams.642-832.v2014-01-11.by.MMFSH.238q
    -74 Cisco.ActualTests.642-832.v2013-04-29.by.Igor.70q
    -33 Cisco.Certkey.642-832.v2014-01-24.by.Toni.14q

    Which is the valid dump?

    Regards!

  11. LOLOPUTERO
    May 22nd, 2014

    74 Cisco.ActualTests.642-832.v2013-04-29.by.Igor.70q ONLY!!!

  12. Azeem
    July 23rd, 2014

    Can anyone please send me valid dums and tickets of T-shott.
    I will be really thankful to him

    Azeem@cib.gov.sa

  13. Chika
    August 12th, 2014

    In R6, configure a default root to R1, Ip route 0.0.0.0 0.0.0.0 209.65.200.225, otherwise R2, R3 and R4 cannot ping the loopback interface of R6 209.65.200.241.

  14. Oluwafunso
    September 23rd, 2014

    Pls can anybody give me the link to download cisco packet tracer 6.1.1 and VCE for free ?

  15. Johnny
    September 27th, 2014

    Link provided @ PT Tickets Forum Page 2 here

  16. LuigiBros
    November 19th, 2014

    What about the R1 and R6 configuration?

    R1
    interface s0/1
    ip address 209.65.200.225 255.255.255.252
    no shutdown

    R6
    interface s0/0
    ip address 209.65.200.226 255.255.255.252
    no shutdown
    !
    interface Loopback0
    ip address 209.65.200.241 255.255.255.252

    They will be already configured, right?

    Thank you so much

  17. Anonymous
    December 21st, 2014

    Can somebody send me link to download for free Pocket tracer 6.1?

  18. George
    December 21st, 2014

    @Anonymous:
    Pls fimd PT 6.1 Download Link within post from Sami by July 25th, 2014 on this page:
    http://www.networktut.com/practice-tshoot-tickets-with-packet-tracer/comment-page-2#comments

  19. Rizwan pk
    December 26th, 2014

    how redistributes the eigrp over bgp in frame relay switch
    plz tell soon as soon………..
    at rizwanashraf0071@outlook.com

  20. John
    December 26th, 2014

    Rizwan pk:

    EIGRP AIN’t redistributed over bgp within any frame relay switch etc. within the current (642-832)TSHOOT Exam Topology!

    Within the (642-832) Toplogy, a default IPv4 route pointing towards the @ / ISP and the external Server segment: 209.65.200.240/29 are learned on R1 from the ISP router via eBGP.

    Also EIGRP and OSPF are mutual redistributed into each other on the R4 router within the (642-832) Topology.

    But all this it’s quite another storry…

    Thus There seems to be some kind of misunderstanding regarding the operation for the (current 642-832) TSHOOT exam Topology within your Post above!?

  21. Balls
    January 11th, 2015

    Hi Guys,

    I thought there were only drag and drop, multiple choice and trouble tickets. Is there labs in this exam also?? or are these apart of the trouble tickets?

  22. man
    January 17th, 2015

    hi , i try use ospf instead of eigrp but it seem not work.
    On able to form neighbor between R2 and R3, other are not.
    Please advice.

  23. man
    January 17th, 2015

    Only* able to form neighbor between R2 and R3, other are not

  24. Steve
    January 27th, 2015

    Does anyone have Dumps and cbt nuggets for TSHOT?

  25. me@here.com
    March 10th, 2015

    nice to have…good to know..almost NONE of this is in the 300-135 exam.

    the issues in the ticket-sim are almost all OSPF / EIGRP redistr or config issues.

    – M

  26. networktut
    March 10th, 2015

    @me@here.com: This tutorial only explains how it works. In the real exam it uses OSPF not EIGRP but the theory is nearly the same.

  27. CCNP
    April 8th, 2015

    will these labs appear in the exam?

  28. CCNP – TSHOOT
    April 21st, 2015

    please answer me there is lab real exam!?? or not because i have no idea about this lab all what i know there is Drag&Drop Questions and MCQ and Simlets and Tickets.

  29. networktut
    April 21st, 2015

    @CCNP – TSHOOT: Please read the TSHOOT FAQs: http://www.networktut.com/tshoot-faqs-tips
    This “EIGRP over Frame Relay and EIGRP Redistribute Lab” is not on the exam.

  30. alkaabi
    January 1st, 2016

    hello friends ..

    can anyone send me the updated dumps for ccna R&S on {email not allowed}

    thanks..