Home > Ticket 15 – IPv6 GRE Tunnel

Ticket 15 – IPv6 GRE Tunnel

March 16th, 2015 in TSHOOT v2 Go to comments

Problem: Loopback address on R1 (2026::111:1) is not able to ping the loopback address on DSW2 (2026::102:1).

Configuration of R3:
!
interface Tunnel34
 no ip address
 ipv6 address 2026::34:1/122
 ipv6 enable
 ipv6 ospf 6 area 34
 tunnel source Serial0/0/0.34
 tunnel destination 10.1.1.10
 tunnel mode ipv6
!

Configuration of R4:
interface Tunnel34
 no ip address
 ipv6 address 2026::34:2/122
 ipv6 enable
 ipv6 ospf 6 area 34
 tunnel source Serial0/0/0
 tunnel destination 10.1.1.9
!

Answer:
Ans1) R3
Ans2) Ipv4 and Ipv6 Interoperability
Ans3) Under the interface Tunnel34, remove ‘tunnel mode ipv6’ command

Comments (50) Comments
Comment pages
1 2 3 697
  1. Mark
    March 16th, 2015

    On R4 Tunnel34

    Shouldn’t it be:

    tunnel source Serial0/0/0.34 <—- (missing .34 in above command?)

    Just like the Tunnel34 setup on R3 above!?

  2. Mark
    March 16th, 2015

    Above Post was for Network Tut Admin!

  3. networktut
    March 17th, 2015

    @Mark: The IPv4 Layer 3 Topology has a mistake when showing R4 connects to R3 via S0/0/0.34. In fact R4 is using S0/0/0 main interface (while R3 uses S0/0/0.34 interface).
    Same for R1-R2 connection.

  4. Mark
    March 17th, 2015

    @Network.tut:
    Ohh, sorry by interrupting on that, although the I/F labeling apears a little unlogical within the specific Topology / Ticket :)

  5. me
    March 17th, 2015

    seems simple now….

    THIS was a clear example of how dumps can hurt you more then help you:

    I expected R2 OSPF issue when I saw Ipv6…..spent the next 10 minutes TURNED around looking for an issue between DSw1 and R4 (yes, I know that is DUH!)

    Finally stopped my spinning gear and re-started troubleshooting for REAL and it took me 1 min to figure out that the issue was between R3 and R4 : but by this point my head was so unclear that I kept trying to find the option on R4 to turn Tunnel Mode IPv6 ON on r4….DOH!

  6. MK
    March 17th, 2015

    “Ipv4 and Ipv6 Interoperability (not sure)” if this is the actual answer?

    kindly anyone confirm, thanks!

  7. Anonymous
    March 17th, 2015

    I cannot see the topology diagram neither the questions for this ticket. Where can i find it?

  8. networktut
    March 17th, 2015

    @Anonymous: You can find all the (common) diagram for TSHOOT exam at http://www.networktut.com/tshoot-share-your-experience
    For the question, it only says that “Loopback address on R1 (2026::111:1) is not able to ping the loopback address on DSW2 (2026::102:1).” Find out the problem.

  9. me
    March 18th, 2015

    Answer:
    Ans1) R3
    Ans2) Ipv4 and Ipv6 Interoperability (not sure) -> YES, we are sure…this is where that is
    Ans3) Under the interface Tunnel34, remove ‘tunnel mode ipv6ip’ command

  10. Rods
    March 18th, 2015

    Shouldn´t we place the command “tunnel mode ipv6ip” under R4 instead of remove it from R3?!
    That mode indicates that IPv6 with travel through IPv4 tunnel isnt it?

  11. networktut
    March 19th, 2015

    @me: Thanks for your information. We are now sure about Ans2.

  12. Mark
    March 26th, 2015

    @Rods:
    At exam you’ll need to remove “tunnel mode ipv6ip” under R3 instead of adding it on R4 – This way you’re running a std. GRE Tunnel between the devices, on which you can throw also IPv6 based traffic, as needed within the relevant exam ticket lab.
    However within indeed the PT IPv6 Tunnel Training Lab, you’ll need to place the command “tunnel mode ipv6ip” under R4 instead of removing it from R3, simply because PT 6.1 cannot transfer indeed IPv6 based traffic through a std. GRE Tunnel, as requried – (it’s due to a tech limitation within the current PT 6.1 Simulator).
    So please don’t get confused about this minor issue.
    Hope this helps!?

  13. MAZ
    March 31st, 2015

    please , can help me !!
    any configurations need to be add in the exam or just multiple choices !!!!!

  14. MAZ
    March 31st, 2015

    please , any body can help me !!
    if any configurations need to be add or change in the exam,, or just multiple choices !!!!!
    please i have exam next Saturday ,,,

  15. FACRUZ
    April 1st, 2015

    I do not understand why remove ‘tunnel mode ipv6ip’ in R3
    if the tunnel 34 is running over (interface Serial0/0/0.34 point-to-point)
    and this use ipv4. and I think we should add, not remove.
    What do you think ??

    interface Tunnel34
    ipv6 address 2026::34:1/122
    ipv6 ospf 6 area 34
    tunnel source Loopback3
    tunnel destination 4.4.4.4
    !
    interface Serial0/0/0.34 point-to-point
    description Link to R4 s0/0/0.34
    ip address 10.1.1.9 255.255.255.252
    frame-relay interface-dlci 343
    !

  16. Mark
    April 2nd, 2015

    Yes FACRUZ – But the problem relies on the fact, that the provided PT 6.1 TSHOOT Tunnel Config can only transport IPv6 based traffic by help of: “tunnel mode ipv6ip” in R3 and R4 –

    However at exam and on IRL Cisco Networks, you can Transport IPv6 based traffic by help of ALSO a std “GRE tunnel”!

    Then if you simply remove the “tunnel mode ipv6ip” in R3, the tunnel will now revert to the standard “GRE” mode, and you’ll thus be able to transport the needed IPv6 Traffic over the R3/R4 GRE Tunnel!

    Hope this helps!?

  17. FACRUZ
    April 2nd, 2015

    @Mark thanks for you answer.

  18. sza
    April 9th, 2015

    actually;
    Configuration of R3:
    !
    interface Tunnel34

    tunnel mode ipv6 % it isn’t “tunnel mode ipv6ip”
    !

    Ans1) R3
    Ans2) Ipv4 and Ipv6 Interoperability
    Ans3) Under the interface Tunnel34, remove ‘tunnel mode ipv6’ command

  19. Mike
    April 9th, 2015

    sza:
    @exam = Yes, but the PT labs here, seems to be based on tunnel mode “ipv6ip” since the “ipv6” tunnel mode & removal ain’t supported within the current PT simulator.
    BTW, has anybody here got an URL on the Internet, for a CLEAR description on also the Cisco tunnel mode “ipv6” (regarding how to configure and use also this IPv6 tunnel type)!?
    ALL available descriptions on the Internet, mostly deals with indeed the tunnel mode “ipv6ip”, and thus it could be interesting to read a bit more about also the “ipv6” tunnel mode – (don’t think it’s described within the official CCNP “Route” Study Guide, alongside the OTHER Cisco tunneltypes !?)
    Thank you in advance!

  20. tutt
    April 20th, 2015

    correct answer???

    ipv6 or ipv6ip????

  21. Its About to go down
    April 23rd, 2015

    Can anyone tell me if Galvin 56 question still valid

  22. John
    April 24th, 2015

    correct answer???
    ipv6 or ipv6ip????

    which is correct??

  23. NB
    April 26th, 2015

    Tomorrow I am going to appear in TSHOOT exam. Not very confident but enough prepared to give it a try. Hope that I will get good tickets along with other MCQs/D&D Ques…. Will share my experience here with you guys tomorrow.Cheers!!!!!!!!!!!!!!

  24. KKK
    April 26th, 2015

    @NB I will take TSHOOT exam tomorrow too! In Moscow 8))

  25. Al
    May 1st, 2015

    @all:

    WHO on this site is able to describe and explain the difference between Cisco Tunnel Mode: “IPv6” versus “IPv6IP”???

    (e.g: How do they operate differently, and in what situations should each of the two modes be used)???

    Thx in advance!

  26. Al
    May 1st, 2015

    Route Professor, are you still here???

  27. peter
    May 5th, 2015

    in each ticket we have 3 questions right?
    can we do for example question 2 before question 1 , or for example question 3 before question 1 or question 2?

  28. Ali imran
    May 7th, 2015

    yeh @ peter

  29. Susanne
    May 8th, 2015

    The encapsulation mode for the tunnel interface defaults to generic route encapsulation (GRE), so this command “tunnel mode ipv6” is considered optional (not needed). However, if you want a mode other than GRE, then you need to configure it.
    The command “tunnel mode ipv6ip” is used when configuring IPv6 as passanger protocol and ipv4 as transport protocol, however the command “tunnel mode ipv6” is used when the tunnel is created over an ipv6 transport network – see doc. http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/interface/configuration/xe-3s/ir-xe-3s-book.pdf

  30. Ali imran
    May 9th, 2015

    anyone tell mee in this scenario client 1 is able to ping 10.1.1.1 or 10.1.1.2 and the client take DHCP from R4 or not ? please do let me know

  31. Al
    May 10th, 2015

    @Sus:

    THANK’s!!! – What a Cool description for the various Cisco Tunnel Mode Configs! – Really likes it!!!

    So:

    Tunnel Mode: ipv6ip => “ipv6” is our Passenger and “IPv4” is our Transporter

    Tunnel Mode: ipv6 => “ipv6” is our Passenger and “IPv6” is also our Transporter at the same time

    However, also within the new? TSHOOT v.2 Topology, there don’t seems to be any Basic “ipv6” Transporter between R3 and R4 for this Tunnel purpose? – Ain’t that correct? – Or?

    Ain’t the Serial R3 R4 Interfaces basicly configured something like this within TSHOOT v.2 Topology:

    R3:
    interface Serial0/0/0.34 point-to-point
    description Link to R4 s0/0/0.34
    ip address 10.1.1.9 255.255.255.252
    frame-relay interface-dlci 343
    clock rate 2000000

    And R4:
    interface Serial0/0/0.34 point-to-point
    description Link to R3 s0/0/0.34
    ip address 10.1.1.10 255.255.255.252
    frame-relay interface-dlci 434
    clock rate 2000000

    (Basicly excluding any IPv6 connectivity between the two Routers!)

    If so – It don’t make much sense to me, removing a tunnel-mode of “ipv6” on a Tunnel Config that basicly lack’s an operational IPv6 “Transporter” on the R3/R4 link, as the Ticket 15 solution above suggests!?

    Thus, I would still think the most logical and correct solution should be “no tunnel mode ipv6ip, simply because we have an operational “ipv4” Transporter on this R3/R4 link!? – Or have I misunderstood something in this regard?

    Thank You!

  32. Susanne
    May 11th, 2015

    @Al
    Thanks for the question.
    The network between R3 and R4 is an IPv4 transporter network.
    To avoid that this question could be answered with either removing the command or adding the command, they added a completely wrong command, which does not belong to the network infrastructure. Therefore the answer is to remove the command by entering “no tunnel mode ipv6”.

    Moreover, this question also checks your knowhow within the tunnel technology, which commands to be used in which content – IPv4 transport or IPv6 transport network.

  33. Al
    May 11th, 2015

    Thank’s for answering my question above Miss S!
    All in all, VERY informative, I’ll say!
    Ok, I see your point described within your answer, but (in my world), it still appears as a little / kind of weird solution within a purely IPv4 based Transporting environment in the ticket, I think – (perhaps it’s just me!?) :)
    Never the less, I think, the issue has been contributing to a good an very learningfull discussion :)
    Wish you well @ exam!

  34. LooseCannon
    June 7th, 2015

    From the lab I downloaded from this site tunnel mode ipv6ip is under Tunnel34 on R3 and R4?

  35. al
    June 8th, 2015

    LooseCannon:
    Yes, but It’s b-cause PT 6.1 (and 6.2) doesn’t support the IOS tunnel mode: “ipv6” and also the PT sim Apps cannot transfer IPv6 based Traffic through a std. GRE Tunnel – (as it is possible IRL)…

  36. Tahap
    June 14th, 2015

    Hi everyone tomorrow morning I’m going to go to take the t-shoot exam, But i am a little bit uneasy. Can someone help me, how do i determine the IPV6 GRE TUNNEL issue. How can i understand the problem originate from GRE TUNNEL ????????
    Kind regards
    Taha From Turkey

  37. Anonymous
    June 14th, 2015

    As per ticket questions there only two questions like ” Loopback address on R1 (2026::111:1) is not able to ping the loopback address on DSW2 (2026::102:1). ” hence you can easily identify problem,

    problem 1 : redistribute rip RIP_Zone on R4
    problem 2 : GRE tunnel on R3
    hope it will clear ..

    Hi Networktut : please correct if i am wrong

  38. Anonymous
    June 14th, 2015

    hey all i am going to appear exam next week , could someone confirm if D and D question are still coming and if so then can someone post these questions please .

  39. Anonymous
    June 15th, 2015

    Hello.. i passed my TSHOOT yesterday. All TTs are valid and simlets are HSRP and EIGRP.
    Thanks to everyone and special thanks to Networktut for making me a CCNP professional :)

  40. Anonymous
    June 15th, 2015

    @ Anonymous
    No D and D Questions

  41. Tahap
    June 17th, 2015

    Thank you Anonymous with little bit delay.
    I’ve passed my axam at 15.06.2015 with 951 scoores. I made half&half mistake and i think it’s related with the Vlan Filter list.

  42. Asif
    June 21st, 2015

    Total – 16 TTs —- all tickets can be indentified by pinging from client 1 to any device

    1. Client 1 can ping webserver=== 3 IPv6 tickets or 1 HSRP ticket (easily identifiable as the questions would indicate the problem)
    2. Client 1 can ping R1 (10.1.1.1) or R2(10.1.1.2)====4 TTs on R1

    3.Client 1 can ping Default Gateway or DSW1===3 TTs on R4

    4. Client 1 cant ping even Default Gateway or DSW1= 5 TTs

    a. client 1 & 2 cant ping each other — port security
    b. client 1 & 2 can ping each other but cant ping DSW1/Def. gateway– 4 TTs as below

    1. ASW1 access vlans=======check ASW1 interfaces fa1/0/1 & fa1/0/2 for “switchport access vlan 10 ” missing command

    2. ASW1 switch port trunk/switch to switch connectivity=====if “switchport access vlan 10 ” is present then check ASW1 Port channel 13 & 23 if vlan 10 is allowed or not.

    3. DSW1 vlan acccess map/vlan filter============= if ASW1 config is ok, check for VLAN access map in DSW1 which :DSW1 has a vlan filter10 that is dropping anything from passing through it on vlan 10

    4. R4 DHCP misconfiguration: if the above 3 configurations checks are ok, its the DHCP misconfiguration on R4.

    This is the strategy i have prepared, where i we just need to ping all the devices from Client 1 to identify each tickets. I dont have a strategy for Layer2 tickets hence i am just going to check each device like ASW1, DSW1 etc for missing configuration.

  43. ZWS
    July 3rd, 2015

    Passed exam today, B I G thank’s to Networktut.

  44. eboy
    July 5th, 2015

    will this show on the description of the question that the loopback cannot be reached?

  45. Muhammad
    July 7th, 2015

    @ All who already appeared in exam

    How we can identify the IPv6 tickets, Is there question statement is changed with the reference of other IPv4 ticket where normally we can see “Client is not able to ping web server” What is the Question statement for IPv6 Tickets? Please help urgent query

    Thanks

  46. Diane
    July 7th, 2015

    Muhammad:
    Just study Ticket # 15 (and # 16) Descripitions @ top of their specific pages here, to get some help for u’r question.

  47. Muhammad
    July 9th, 2015

    @ Diane Thanks Buddy

  48. Mohamed
    July 12th, 2015

    is this ticket same ticket 15 in packet tracer ???

  49. al
    July 12th, 2015

    Mohamed:
    Nope, ticket 15 within the packet tracer package deals with a wrong IP helper addr problem, so it’s quite another ballgame compared to this (GRE) Tunnel problem ticket :)
    Since the current PT simulator (rel. 6.1 and 6.2) don’t support a tunnel mode of just “IPv6”, this ticket 15 isn’t availble within the PT TSHOOT Ticket Package currently presented here. – (I guess?)

Comment pages
1 2 3 697