Home > HSRP Sim

HSRP Sim

March 22nd, 2018 in Simlets Go to comments

Special thanks to Yahya who created this HSRP simlet with EVE-NG emulator and you can download it here.

Question 1

Explanation

Check the configuration of R1 with the “show running-config” command:

R1_show_run_track.jpg

R1 connects to R5 via E0/1 interface but R1 is tracking E0/0 which connects to R2 -> when the link between R1 & R5 fails the HSRP priority of R1 is still the same. To correct this problem we have to change the tracking interface to E0/1.

Question 2

Explanation

Check the link between R1 & R2 where HSRP group 2 is running (interface E1/0)

R1_show_run_access_list.jpg

As we see R1 is using access-list 102 to filter traffic coming to interface E1/0 (inbound direction). Continue checking the access-list 102 of R1:

R1_show_run_access_list2.jpg

R1 is blocking any traffic send to 224.0.0.102. Notice that in the syntax of an access-list, the source address is always defined before the destination address. “224.0.0.102” is the muticast address which HSRP version 2 uses to send Hello packets to (instead of 224.0.0.2 of HSRP version 1). Therefore all HSRP sent from neighbor (R2 in this case) to R1 is dropped. R1 keeps sending HSRP Hello packets and think it is the active HSRP router.

Question 3

Explanation

Checking what is preventing the two networks 172.16.10.0/24 & 172.16.20.0/24 from learning on R4.

R4_show_run_distribute_list.jpg

There is a distribute-list applied on R4. Notice that a distribute-list is often used to control which routing updates should be sent or received on a router. So we should check what this distribute-list is used for. This distribute-list is based on access-list 1 so we will continue checking this access-list:

R4_show_run_access_list.jpg

This access-list explicitly blocks the two networks 172.16.10.0/24 & 172.16.20.0/24 from populating into R4 routing table.

Question 4

Explanation

Check the routing table of R4 with the “show ip route” command:

R5_show_ip_route.jpg

We see that there is no route is learned from R4.

Check R4 and R5 with the “show ip interface brief” command, we notice that the interface E0/0 of R4 (which is connected to R5) and interface E0/0 of R5 (which is connected to R4) are running DHCP but it does not have any IP address.

R4_show_ip_int_brief.jpg

-> Therefore this is the issue.

Comments (49) Comments
Comment pages
1 2 695
  1. networktut
    October 16th, 2018

    @Anaonymous: In this case the distribute list uses the ACL so D is the correct answer.

  2. RKS29
    October 21st, 2018

    @Anaonymous:
    ACL is not blocking any traffic on the interface connected to R2 hence E cannot be the answer. As per the given simulation, D is the Answer.

  3. Hukes
    October 31st, 2018

    Hi, sorry for my question. Where are que questions for the answers/explanation

  4. Hello
    November 7th, 2018

    Q3 – The routing table of R4 shows no entries for 172.16.10.0/24 and 172.16.20.0/24. The answer on this page is D. The distribute-list configured on R4 is blocking route entries. However, the Simlet notes the right answer as being “The ACL configuration on R4 is blocking inbound traffic on the interface connected to R2. I understand that the ACL is the actual mechanism that will do the blocking, but it won’t do anything unless the distribute-list activates it. Which is the correct answer for the test?

  5. Hello
    November 7th, 2018

    networktut – your response to Anaonymous is that the correct answer is D, distribute list is the right answer, but the networktut simlet notes it is the ACL that is the correct answer. Can you please clarify which is actually the correct answer for the test (if known), and make a correction to either the answer on the question (D or E) and the simlet.

  6. Hello
    November 7th, 2018

    networktut – I will say that PassLeader says the correct answer is the distribute-list configured on R4 is blocking the router entries.

  7. networktut
    November 7th, 2018

    @Hello: In both simlet and answer on this page the answer is always distribute list. Please check again.

  8. optimus
    November 11th, 2018

    @networktut,
    I am premium member, In your explanations above here, qx3 answer is D and qx4 ans is C, but in your simlet, these answers are opposite. plz clearify

  9. networktut
    November 11th, 2018

    @optimus: We checked but found no problem. The questions in the quiz are shuffled each time you practice so please read the questions carefully.

  10. KING
    December 3rd, 2018

    JUST 20 $, TO GUARANTEE your Success.

    CCNA R&S
    200-125 CCNA = 565 Q&As
    100-105 ICND1 = 347 Q&As
    200-105 ICND2 = 268 Q&As
    CCNP R&S
    300-101 ROUTE = 768 Q&As
    300-115 SWITCH = 287 Q&As
    300-135 TSHOOT = 180 Q&As
    CCIE R&S
    400-101 WRITTEN = 114 Q&As

    Get at BELOW Link
    Remove SPACES:

    go o . g l /FkMoqt

  11. Sam
    December 16th, 2018

    @networkTUT : in HSRP sim; Do I have to apply any command or it’s only multiple choices ?
    Thanks

  12. CCNP Wireless
    December 24th, 2018

    @ Sam,

    through using show commands you should determine the root cause. then you will answer to the question using multi chose

  13. Sherif Hegazy
    January 1st, 2019

    @King ,

    what about switching , how to follow with you

  14. Anonymous
    February 3rd, 2019

    Jesus.. DHCP on uplink, what is wrong with this people from cisco who created that…

  15. win
    February 4th, 2019

    please can anyone help me I have to dial in this month

  16. Curious
    February 5th, 2019

    On question 4 in the HSRP_Simulator I run the command show interface eth0/0 and it showed the IP address for the interface (I thought it was learned via DHCP)

    R4#show interface eth0/0
    Internet address is 192.168.2.1/24

    R5#show interface eth0/0
    Internet address is 192.168.2.2/24

    But the ping failed. I was confused because every answers seemed wrong. Now I will trust on show ip interaface brief

  17. Ringding
    February 22nd, 2019

    I saw the same thing as Curious. Why does “show int eth0/0” show an IP address if DHCP isn’t working?

  18. Sepp
    February 24th, 2019

    I read these two simlets are out of the exam. Is that true?
    What is currently the surrogat?!

  19. toink
    March 5th, 2019

    Can anyone share the questions for HSRP simlet?? I dont see the questions for this simlet in the pdf compilation (Tshoot_Feb_2019) . Thanks x5 for someone who will help.

  20. manhattan
    March 27th, 2019

    @toink
    the answers are above at this page!

  21. natus
    April 19th, 2019

    where is question off bgp sim and hsrp sim ???

  22. Anaonymous
    April 20th, 2019

    what are the questions for HSRP Sim?
    I see the answers but no the questions

  23. Jackie
    April 22nd, 2019

    Hello Guys,
    Please can someone guide how to start preparing for this Tshoot exam. I have recently passed Switch and Tshoot is my final exam

  24. Bob
    May 1st, 2019

    Has the HSRP Simlet been removed from the exam now? The PDF says

    ‘Note: HSRP Simlets does not appear in the exam any more’

    but there are people here as recently as the 26th of April saying it was in there?

    h t t p s : / / http://www.networktut.com/multiple-choice-questions

    Just starting to prepare for this, last one to do, 4 months to do it…

    Thanks.

  25. Forever More
    May 11th, 2019

    Re question 3

    If you look at where the acl is applied – it’s in OSPF – so it’s blocking the entries from the routing table – not packets from entering the router.

  26. John
    May 13th, 2019

    Passed on May 10th 2019 with 946/1000.
    24 questions on exam: 10 MCQs, 12 tickets, BGP and HSRP simlet.
    Thanks mm for detailed review and you guys here as well as Networktut team.
    Chinese dump is valid however MCQs answers in it are not totally correct.
    You should read all recent comments here to get your own correct answers.
    Good luck!

  27. John
    May 13th, 2019

    Contact: ballking242(at)gmail(dot)com

  28. Fj
    May 22nd, 2019

    Do we have to save configuration on bgp sim or just correcting the configuration should be enough. I heard copy-run to startup doesnt work? Can anyone answer that?

  29. Bob
    June 11th, 2019

    Neither of the .unl files for the simlets have any of the device configs. All I am seeing is the topology. Where are the configs?

  30. James
    June 13th, 2019

    someone knows how to import de simlet to EVE ?

  31. Bob
    June 16th, 2019

    I wound up paying for premium, It’s worth doing it when you are close to taking the exam. The TSHOOT and sims are all configured properly. New MCQ questions are provided as well.

  32. question
    June 18th, 2019

    We are the questions ?????

  33. marimar
    June 20th, 2019

    EVE-NG file for this sim doesnt contain any config. anybody facing same?

  34. Archibald K
    June 24th, 2019

    Hello, to help @marimar: i did set up the EVE-NG topology, using 4 routeurs (R1,R2, R4 and R5), plus an access switch (ASW1) to link R1,R2 and both PCs.

    Here what i configured (and works fine):

    ASW1:

  35. Archibald K
    June 24th, 2019

    ASW1#sh run
    Building configuration…

    Current configuration : 3480 bytes
    !
    ! Last configuration change at 11:19:55 UTC Mon Jun 24 2019
    !
    version 15.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    service compress-config
    !
    hostname ASW1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    no aaa new-model
    !
    !
    !
    !
    !
    !
    !
    !
    ip cef
    no ipv6 cef
    !
    !
    !
    spanning-tree mode rapid-pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    switchport trunk allowed vlan 1,10
    switchport trunk encapsulation dot1q
    switchport mode trunk
    media-type rj45
    negotiation auto
    !
    interface GigabitEthernet0/1
    switchport trunk allowed vlan 1,10
    switchport trunk encapsulation dot1q
    switchport mode trunk
    media-type rj45
    negotiation auto
    !
    interface GigabitEthernet0/2
    switchport trunk allowed vlan 1,20
    switchport trunk encapsulation dot1q
    switchport mode trunk
    media-type rj45
    negotiation auto
    !
    interface GigabitEthernet0/3
    switchport trunk allowed vlan 1,20
    switchport trunk encapsulation dot1q
    switchport mode trunk
    media-type rj45
    negotiation auto
    !
    interface GigabitEthernet1/0
    switchport mode access
    media-type rj45
    negotiation auto
    !
    interface GigabitEthernet1/1
    switchport mode access
    media-type rj45
    negotiation auto
    !
    interface GigabitEthernet1/2
    media-type rj45
    negotiation auto
    !
    interface GigabitEthernet1/3
    media-type rj45
    negotiation auto
    !
    interface Vlan20
    ip address 172.16.20.132 255.255.255.0
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    banner exec ^C
    **************************************************************************
    * IOSv is strictly limited to use for evaluation, demonstration and IOS *
    * education. IOSv is provided as-is and is not supported by Cisco’s *
    * Technical Advisory Center. Any use or disclosure, in whole or in part, *
    * of the IOSv Software or Documentation to any third party for any *
    * purposes is expressly prohibited except as otherwise authorized by *
    * Cisco in writing. *
    **************************************************************************^C
    banner incoming ^C
    **************************************************************************
    * IOSv is strictly limited to use for evaluation, demonstration and IOS *
    * education. IOSv is provided as-is and is not supported by Cisco’s *
    * Technical Advisory Center. Any use or disclosure, in whole or in part, *
    * of the IOSv Software or Documentation to any third party for any *
    * purposes is expressly prohibited except as otherwise authorized by *
    * Cisco in writing. *
    **************************************************************************^C
    banner login ^C
    **************************************************************************
    * IOSv is strictly limited to use for evaluation, demonstration and IOS *
    * education. IOSv is provided as-is and is not supported by Cisco’s *
    * Technical Advisory Center. Any use or disclosure, in whole or in part, *
    * of the IOSv Software or Documentation to any third party for any *
    * purposes is expressly prohibited except as otherwise authorized by *
    * Cisco in writing. *
    **************************************************************************^C
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end

  36. Archibald K
    June 24th, 2019

    R1#sh run
    Building configuration…

    Current configuration : 3852 bytes
    !
    ! Last configuration change at 11:36:57 UTC Mon Jun 24 2019
    !
    version 15.6
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    no aaa new-model
    ethernet lmi ce
    !
    !
    !
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    !
    !
    !
    !
    !
    !
    !
    !
    ip dhcp excluded-address 172.16.10.1
    ip dhcp excluded-address 172.16.10.2
    ip dhcp excluded-address 172.16.10.254
    !
    ip dhcp pool VLAN10POOL
    network 172.16.10.0 255.255.255.0
    default-router 172.16.10.254
    !
    !
    !
    ip cef
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    redundancy
    !
    !
    track 1 interface GigabitEthernet0/1 line-protocol
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    media-type rj45
    !
    interface GigabitEthernet0/0.20
    encapsulation dot1Q 20
    ip address 172.16.20.1 255.255.255.0
    standby 20 ip 172.16.20.254
    standby 20 preempt
    standby 20 track 1 decrement 20
    !
    interface GigabitEthernet0/1
    ip address 192.168.10.1 255.255.255.0
    duplex auto
    speed auto
    media-type rj45
    !
    interface GigabitEthernet0/2
    no ip address
    duplex auto
    speed auto
    media-type rj45
    !
    interface GigabitEthernet0/2.10
    encapsulation dot1Q 10
    ip address 172.16.10.1 255.255.255.0
    standby 10 ip 172.16.10.254
    standby 10 priority 110
    standby 10 preempt
    standby 10 track 1 decrement 20
    !
    interface GigabitEthernet0/3
    no ip address
    shutdown
    duplex auto
    speed auto
    media-type rj45
    !
    router ospf 10
    router-id 1.1.1.1
    passive-interface default
    no passive-interface GigabitEthernet0/1
    network 172.16.10.0 0.0.0.255 area 0
    network 172.16.20.0 0.0.0.255 area 0
    network 192.168.10.0 0.0.0.255 area 0
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    access-list 102 deny ip any host 224.0.0.2
    access-list 102 permit ip any any
    !
    control-plane

  37. Archibald K
    June 24th, 2019

    R2#sh run
    Building configuration…

    Current configuration : 3506 bytes
    !
    version 15.6
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    no aaa new-model
    ethernet lmi ce
    !
    !
    !
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    ip cef
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    redundancy
    !
    !
    track 1 interface GigabitEthernet0/1 line-protocol
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    media-type rj45
    !
    interface GigabitEthernet0/0.20
    encapsulation dot1Q 20
    ip address 172.16.20.2 255.255.255.0
    standby 20 ip 172.16.20.254
    standby 20 priority 110
    standby 20 preempt
    standby 20 track 1 decrement 20
    !
    interface GigabitEthernet0/1
    ip address 192.168.20.1 255.255.255.0
    duplex auto
    speed auto
    media-type rj45
    !
    interface GigabitEthernet0/2
    no ip address
    duplex auto
    speed auto
    media-type rj45
    !
    interface GigabitEthernet0/2.10
    encapsulation dot1Q 10
    ip address 172.16.10.2 255.255.255.0
    standby 10 ip 172.16.10.254
    standby 10 preempt
    standby 10 track 1 decrement 20
    !
    interface GigabitEthernet0/3
    no ip address
    shutdown
    duplex auto
    speed auto
    media-type rj45
    !
    router ospf 10
    router-id 2.2.2.2
    passive-interface default
    no passive-interface GigabitEthernet0/1
    network 172.16.10.0 0.0.0.255 area 0
    network 172.16.20.0 0.0.0.255 area 0
    network 192.168.20.0 0.0.0.255 area 0
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    control-plane

  38. Archibald K
    June 24th, 2019

    R4#sh run
    Building configuration…

    Current configuration : 3339 bytes
    !
    ! Last configuration change at 11:56:27 UTC Mon Jun 24 2019
    !
    version 15.6
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R4
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    no aaa new-model
    ethernet lmi ce
    !
    !
    !
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    ip cef
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    redundancy
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    ip address dhcp
    duplex auto
    speed auto
    media-type rj45
    !
    interface GigabitEthernet0/1
    ip address 192.168.20.2 255.255.255.0
    duplex auto
    speed auto
    media-type rj45
    !
    interface GigabitEthernet0/2
    no ip address
    shutdown
    duplex auto
    speed auto
    media-type rj45
    !
    interface GigabitEthernet0/3
    no ip address
    shutdown
    duplex auto
    speed auto
    media-type rj45
    !
    router ospf 10
    router-id 4.4.4.4
    passive-interface default
    no passive-interface GigabitEthernet0/0
    no passive-interface GigabitEthernet0/1
    network 192.168.2.0 0.0.0.255 area 0
    network 192.168.20.0 0.0.0.255 area 0
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    access-list 1 permit 172.18.30.0
    access-list 1 deny 172.16.20.0
    access-list 1 permit 172.18.20.0
    access-list 1 permit 172.18.10.0
    access-list 1 deny 172.16.10.0
    access-list 1 permit any
    !
    control-plane

  39. Archibald K
    June 24th, 2019

    R5#sh run
    Building configuration…

    Current configuration : 3300 bytes
    !
    ! Last configuration change at 11:55:10 UTC Mon Jun 24 2019
    !
    version 15.6
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R5
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    no aaa new-model
    ethernet lmi ce
    !
    !
    !
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    !
    !
    !
    !
    !
    !
    !
    !
    ip dhcp excluded-address 192.168.2.1
    !
    ip dhcp pool POOL_NETWORK2
    network 192.168.2.0 255.255.255.0
    default-router 192.168.2.1
    !
    !
    !
    ip cef
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    redundancy
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    ip address 192.168.2.1 255.255.255.0
    duplex auto
    speed auto
    media-type rj45
    !
    interface GigabitEthernet0/1
    ip address 192.168.10.2 255.255.255.0
    duplex auto
    speed auto
    media-type rj45
    !
    interface GigabitEthernet0/2
    no ip address
    shutdown
    duplex auto
    speed auto
    media-type rj45
    !
    interface GigabitEthernet0/3
    no ip address
    shutdown
    duplex auto
    speed auto
    media-type rj45
    !
    router ospf 10
    router-id 5.5.5.5
    passive-interface default
    no passive-interface GigabitEthernet0/0
    no passive-interface GigabitEthernet0/1
    network 192.168.2.0 0.0.0.255 area 0
    network 192.168.10.0 0.0.0.255 area 0
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    control-plane

  40. Archibald K
    June 24th, 2019

    I hope this helps. Good luck.

  41. Magir
    June 28th, 2019

    Where can I found the question of the simlets

  42. Magir
    June 28th, 2019

    Where can we found the question of the simlets

  43. Magir
    June 28th, 2019

    Where can I found the question of the simlets?

  44. Soodani
    July 4th, 2019

    It is on top where it says Now you can try the HSRP Simulator here:

    + HSRP Simulator
    but you have to have premium membership to be able to see and practice the questions.

  45. bblack
    July 8th, 2019

    @Bob I did the exam a month ago and still appears
    as bgp simlet, according what I’ve read arround, no always are in the exam, but I got both

  46. BluePhr3ak
    August 8th, 2019

    HI, about the HSRP simulator, do we make correction or do we answer questions? The BGP simulator we make the corrections. The HSRP, do we do thew same?

  47. Anonymous
    August 8th, 2019

    @Archibald K
    Thank You (you might not see this)

  48. Anonymous
    September 16th, 2019

    Hello ,
    ı can open the hsrp sim but ı cant open question page in the lab. Otherwise, last day ı could open it.

    Best Regards

  49. BluePhr3ak
    September 16th, 2019

    Hi All, About the HSRP sim, do we make corrections or only use show commands and answer questions? The BGP simulator we make the corrections. The HSRP, do we do the same?
    Please help!

Comment pages
1 2 695