Home > Redistribute & the effect of the distance EIGRP command Lab

Redistribute & the effect of the distance EIGRP command Lab

November 16th, 2020 Go to comments

We will use this topology in this lab:

Redistribute_Trace.jpg

Purpose of this lab

The purpose of this lab is to check which path R4 will choose to reach 10.1.1.0/24 (located on R1) as there are two paths:
+ The optimal path: R4 -> R2 -> R1
+ The other path: R4 -> R5 -> R3 -> R2 -> R1

In this lab, we will redistribute the directly connected subnet 10.1.1.0/24 to the EIGRP process of R1. On R3 we perform redistribution from EIGRP into OSPF. In this way R4 will learn about the subnet 10.1.1.0/24 via two paths:
+ From R2
+ From R3 & R5

Now, let’s start our lab with GNS3:

Redistribute_topology.jpg

We will see how the Administrative Distance (AD) of this route changes when being redistributed and which route R4 will choose to reach subnet 10.1.1.0/24. Also we will adjust the AD of external redistributed route via the “distance eigrp …” command to see if this AD is changed on other routers.

Initial config

R1
int f0/0
ip addr 10.1.12.1 255.255.255.0
no shut
int f1/0
ip addr 10.1.1.1 255.255.255.0
no shut
router eigrp 1
network 10.1.12.1 0.0.0.0
default-metric 1000000 10 255 1 1500
R2
int f0/0
ip addr 10.1.12.2 255.255.255.0
no shut
int f1/0
ip addr 10.1.23.2 255.255.255.0
no shut
int f2/0
ip addr 10.1.24.2 255.255.255.0
no shut
router eigrp 1
network 10.1.12.2 0.0.0.0
network 10.1.23.2 0.0.0.0
network 10.1.24.2 0.0.0.0
R3
int f0/0
ip addr 10.1.23.3 255.255.255.0
no shut
int f1/0
ip addr 10.1.35.3 255.255.255.0
no shut
router eigrp 1
network 10.1.23.3 0.0.0.0
no auto-summary
router ospf 1
network 10.1.35.3 0.0.0.0 area 0
R4
int f0/0
ip addr 10.1.24.4 255.255.255.0
no shut
int f1/0
ip addr 10.1.45.4 255.255.255.0
no shut
router ospf 1
network 10.1.45.4 0.0.0.0 area 0
router eigrp 1
network 10.1.24.4 0.0.0.0
no auto-summary
R5
int f0/0
ip addr 10.1.35.5 255.255.255.0
no shut
int f1/0
ip addr 10.1.45.5 255.255.255.0
no shut
router ospf 1
network 10.1.35.5 0.0.0.0 area 0
network 10.1.45.5 0.0.0.0 area 0

R6
int f0/0
ip addr 10.1.1.6 255.255.255.0
no shut

Now we perform redistribution on R1 and R3:

R1
router eigrp 1
redistribute connected
R3
router ospf 1
redistribute eigrp 1 subnets

Now we check R2:

R2#show ip route
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 4 subnets
C       10.1.12.0 is directly connected, FastEthernet0/0
D EX    10.1.1.0 [170/30720] via 10.1.12.1, 03:00:48, FastEthernet0/0
C       10.1.24.0 is directly connected, FastEthernet2/0
C       10.1.23.0 is directly connected, FastEthernet1/0

We see R2 learned subnet 10.1.1.0/24 with D EX (EIGRP External route) with AD of 170.

On R3:

R3#sh ip route
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 6 subnets
D       10.1.12.0 [90/30720] via 10.1.23.2, 03:02:32, FastEthernet0/0
D EX    10.1.1.0 [170/33280] via 10.1.23.2, 03:02:32, FastEthernet0/0
D       10.1.24.0 [90/30720] via 10.1.23.2, 02:59:16, FastEthernet0/0
C       10.1.23.0 is directly connected, FastEthernet0/0
O       10.1.45.0 [110/2] via 10.1.35.5, 02:39:35, FastEthernet1/0
C       10.1.35.0 is directly connected, FastEthernet1/0

On R5:

R5#show ip route
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 6 subnets
O E2    10.1.12.0 [110/20] via 10.1.35.3, 01:42:40, FastEthernet0/0
O E2    10.1.1.0 [110/20] via 10.1.35.3, 01:42:40, FastEthernet0/0
O E2    10.1.24.0 [110/20] via 10.1.35.3, 01:42:40, FastEthernet0/0
O E2    10.1.23.0 [110/20] via 10.1.35.3, 01:42:40, FastEthernet0/0
C       10.1.45.0 is directly connected, FastEthernet1/0
C       10.1.35.0 is directly connected, FastEthernet0/0

As we see from the output above, after being redistributed into OSPF, our subnet now has an AD of 110 (the AD of OSPF).

R4 received advertisements about subnet 10.1.1.0/24 from both R2 (with AD of 170) and R5 (with AD of 110) so it will choose the path with lower AD:

R4#show ip route
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 6 subnets
D       10.1.12.0 [90/30720] via 10.1.24.2, 01:45:58, FastEthernet0/0
O E2    10.1.1.0 [110/20] via 10.1.45.5, 01:40:52, FastEthernet1/0
C       10.1.24.0 is directly connected, FastEthernet0/0
D       10.1.23.0 [90/30720] via 10.1.24.2, 01:45:58, FastEthernet0/0
C       10.1.45.0 is directly connected, FastEthernet1/0
O       10.1.35.0 [110/2] via 10.1.45.5, 01:45:58, FastEthernet1/0

We can check if the other path has been learned correctly with the “show ip eigrp topology” command:

R4#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(10.1.45.4)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 10.1.12.0/24, 1 successors, FD is 30720
        via 10.1.24.2 (30720/28160), FastEthernet0/0
P 10.1.1.0/24, 0 successors, FD is Inaccessible
        via 10.1.24.2 (33280/30720), FastEthernet0/0
P 10.1.24.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/0
P 10.1.23.0/24, 1 successors, FD is 30720
        via 10.1.24.2 (30720/28160), FastEthernet0/0

We can shutdown fa0/0 interface on R5 to see if our subnet is learned from the remaining path:

R5:
interface f0/0
shutdown

Check the routing table of R4 again:

R4#show ip route                     
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 5 subnets
D       10.1.12.0 [90/30720] via 10.1.24.2, 02:01:17, FastEthernet0/0
D EX    10.1.1.0 [170/33280] via 10.1.24.2, 00:00:07, FastEthernet0/0
C       10.1.24.0 is directly connected, FastEthernet0/0
D       10.1.23.0 [90/30720] via 10.1.24.2, 02:01:17, FastEthernet0/0
C       10.1.45.0 is directly connected, FastEthernet1/0

Yes, our subnet was learned from R2 with AD of 170.

Now “no shut” interface fa0/0 of R5

R5:
interface f0/0
no shutdown

Let’s try to lower the AD of EIGRP External route to 91 to see if which path R4 would choose:

R1
router eigrp 1
distance eigrp 90 91 //Changes the AD to 90 for internal EIGRP routes and changes the AD to 91 for EIGRP external routes

Check R2 to see if the AD of EIGRP External route has been changed or not:

R2#clear ip route *
R2#show ip route
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 4 subnets
C       10.1.12.0 is directly connected, FastEthernet0/0
D EX    10.1.1.0 [170/30720] via 10.1.12.1, 00:00:30, FastEthernet0/0
C       10.1.24.0 is directly connected, FastEthernet2/0
C       10.1.23.0 is directly connected, FastEthernet1/0

No, R2 could not learn the new AD that we configure on R1. We can conclude that the “distance eigrp …” command only changes the AD of EIGRP routes on the local router.

Next we will remove the “distance eigrp” command on R1 and try it on R4:

R1
router eigrp 1
no distance eigrp 90 91

R4
router eigrp 1
distance eigrp 90 91

Now the routing table of R4 is shown below:

R4#clear ip route *
R4#show ip route
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 6 subnets
D       10.1.12.0 [90/30720] via 10.1.24.2, 00:00:05, FastEthernet0/0
D EX    10.1.1.0 [91/33280] via 10.1.24.2, 00:00:05, FastEthernet0/0
C       10.1.24.0 is directly connected, FastEthernet0/0
D       10.1.23.0 [90/30720] via 10.1.24.2, 00:00:05, FastEthernet0/0
C       10.1.45.0 is directly connected, FastEthernet1/0
O       10.1.35.0 [110/2] via 10.1.45.5, 00:00:11, FastEthernet1/0

Our subnet is learned via the optimal path directly from R2 now!

You can download the final config of this lab here.

Comments (10) Comments
  1. Raaf-NL
    November 27th, 2020

    This part is not correct:
    The final step is not correct:
    R4
    router eigrp 1
    no distance eigrp 90 91

    it should be:
    R4
    router eigrp 1
    distance eigrp 90 91

  2. networktut
    November 27th, 2020

    @Raaf-NL: Yes, thanks for your detection, we have just fixed it!

  3. Nyck
    April 15th, 2021

    Hello,
    I am redoing it on GNS3. Ok. I am getting the understanding.
    However, what are the questions concerning this LAB during the exam ?

  4. Anonymous
    May 20th, 2021

    HEI, DID SOMEONE TOK THE ENARSI EXAN THIS WEEK ?

  5. Marvellous
    October 9th, 2021

    How many simulation in the exam?

  6. BC
    February 15th, 2022

    Oh wow I never really thought about it before. Even though the word “redistributed” connected is used I never put two and two together and thought of it as a external route for all those connected. Also thanks for sharing the distance command only works on the local router.

    One thing and maybe this is just for the test question scenario, but why would you not just add the connected routes to EIGRP with the network command? anytime I want to advertise routes in a routing protocol I always add them to the network command to go to the next router I am forming relationship with.

    Just seems odd not to do it that way or is there something I am missing about connected routes?

  7. Francisco Antonio
    March 12th, 2022

    Nice job!!! well done!

  8. Anonymous
    August 10th, 2022

    @BC – Network 10.1.1.0/24 is not added in Network Command because then it will not be added as a redistributed route but as a EIGRP Inernal route and will be advertised to R4 with an AD of 90 and not as an AD of 170. Hence R4 will prefer Route of R2 > R1 to reach network 10.1.1.0/24

  9. Anonymous
    September 6th, 2022

    does enarsi include labs on the cert exam?

  10. Bank
    June 27th, 2023

    Hi sir.

    I need update diagram of Re-distribution LAB Exam (Including Question would be good).
    Pls send to me at Email : prisonerpriest(at)hotmail.com

    Thx boss.