Home > BGP Sim

BGP Sim

February 4th, 2017 in Simlets Go to comments

Question

Loopback0 is used for IBGP peering while physical interface address is used for EBGP. Identify the IBGP issues on R1 to R2, R3 and EBGP issues to RA and fix them so that the “show ip bgp” command on R1 will display all loopback interfaces of other routers.

BGP_Topology.jpg

Special thanks to Yahya who created this BGP simlet with EVE-NG emulator and you can download it here.

Configs on R1:

This lab is for BGP only so we only need to check BGP section

R1#show running-config
—-output omitted—-
router bgp 64520
network 172.16.1.1 mask 255.255.255.255
neighbor IBGP peer-group
neighbor IBGP remote-as 64550
neighbor IBGP update-source loopback0
neighbor 172.16.2.2 peer-group IBGP
neighbor 172.16.3.3 peer-group IBGP
neighbor 209.165.200.2 remote-as 64525

—-output omitted—-

Solution

We see there are two issues here (two commands in bold), the first one is IBGP issue and the second one is EBGP issue.

R1(config)#router bgp 64520
R1(config-router)#neighbor IBGP remote-as 64520
R1(config-router)#no neighbor 209.165.200.2 remote-as 64525
R1(config-router)#neighbor 209.165.201.2 remote-as 64525

Note:
+ In the second statement we fix the IBGP group to “remote-as 64520” without removing the wrongly configured IBGP group (“neighbor IBGP remote-as 64550”) because if we remove this statement, other related statements of IBGP (three statements “neighbor IBGP update-source Loopback0”, “neighbor 172.16.2.2 peer-group IBGP”, “neighbor 172.16.3.3 peer-group IBGP”) will be removed automatically because IBGP group no longer exists.
+ Also in statement 2 the “IBGP” group must be written in capital. You will receive an error if writing it in lowercase.
+ The IP addresses in the exam are different but the concept is still the same so please read the question carefully

After solving the problem don’t forget to verify with the “show ip bgp” command. You must see all the Loopback interfaces of other routers. Otherwise please check your commands again.

Comments (47) Comments
Comment pages
1 4 5 6 993
  1. Fail exam
    May 21st, 2019

    I just failed exam.

    In BGP sim I do not have options to save config. Does anyone can tell me how to save my work?

    wr
    copy running-config startup-config – not working

  2. caj
    June 1st, 2019

    I have the next week, pls, can any one with the current dump share with me at: {email not allowed}

  3. Riaz
    June 13th, 2019

    i have exam on 24 june . if any have valid dumps please share. libra.ali1973 @ gmail . com

  4. Robert
    June 20th, 2019

    no need to save your config

  5. marimar
    June 20th, 2019

    EVE-NG file for this sim doesnt contain any config. anybody facing same?

  6. Lexxa
    June 26th, 2019

    Hello, After solving the problems whit the new comands the configuration in the R1 does not change so if type sh ip bgp i can not see all the Loopback interfaces of other routers.
    Do i have to save the configuration

  7. CONSULA
    July 3rd, 2019

    Hello Networktut, the sim provided is not working. After entering the commands, the running config doesn’t change. Is this a bug?

  8. CONSULA
    July 3rd, 2019

    Hello @Networktut, the sim provided is not working. After entering the commands, the running config doesn’t change. Is this a bug?

  9. networktut
    July 4th, 2019

    @CONSULA: It is not a bug. Our simulator can only show the initial config.

  10. Rosso
    July 5th, 2019

    I have no initial config. Does anybody have it?

  11. tshoots
    July 10th, 2019

    Use your own subnets to create a full topology and make sure you redistribute between protocols. For BGP you only advertise the loopbacks and then this will show up in the ‘show ip bgp’. This will also include the subnets of all the other networks. If you can ping the loop back of R3 from the loopback of RA, then your config should be sweet.

  12. Shraeven
    August 7th, 2019

    I just sat this about an hour ago and failed this simlet.
    It’s still current

  13. TTL
    August 8th, 2019

    @ Networktut,
    Could you please update BGP Simlet? Many are getting BGP Simlet in the exam since August.

  14. Matty
    August 8th, 2019

    Hey guys, Anyone can respond kindly to this message? Do you think the premium membership will help to pass T-SHOOT exam even though there seems to be new questions on the exam?

    Any ideas?

  15. Anonymous
    August 10th, 2019

    @Matty
    Yes, I used it before. Go for it.

  16. Jude
    August 13th, 2019

    Hi Guys, I need some advice about this BGP simlet last time I did it saving the configuration didn’t work with COPY RUNNING-CONFIG STARTUP-CONFIG or COPY RUN START I have been reading that this will Auto-save the configuration, just to confirm as I am preparing sit the exam soon.

    Also do the wrong configuration in the real exam need to be removed or just configure the expected correct configuration for IBGP & EBGP? Many thanks & kind regards guys.

  17. oba2019
    August 16th, 2019

    Please do we need to configure in the exam just like in real life situation or we just need to identify the error and pick the answers? I will appreciate your response to my question. thank you.

  18. Jasper
    August 17th, 2019

    Hi I sat this eam yesterday and the simlet is correct, however I could not save the config either.
    Simlet 100%

  19. naz
    August 17th, 2019

    hi guys
    I really appreciate your response . can anyone pls tell me that after changing the config , what shall I do
    do I need to enter Exit after changes or just do the changes .
    that’s it

  20. GNS3Talk
    August 18th, 2019

    I just created a GNS3 topology which you can play with.
    It’s configured with the correct loop back addresses and the BGP peer groups.
    The topology can be downloaded from here: https://drive.google.com/file/d/19Zv2JFDUmGB4U6rDSVzUROqhBZxJtfhQ/view?usp=sharing
    Don’t forget to follow my channel for 12 of the best TSHOOT tickets you can find on YouTube.
    https://youtube.com/c/GNS3Talk

  21. Thsoothelp
    August 20th, 2019

    @GNS3Talk
    Yuou can send me only the .cfg equipment ? i’ve an older version og GNS3
    THX regards

  22. Biko
    August 22nd, 2019

    Any change in BGP lab ???
    Any someone tell me

  23. Giant
    August 22nd, 2019

    Why uploading labs with no startup configs, WTF ?

  24. JRP
    August 23rd, 2019

    In BGP sim I do not have options to save config. Does anyone can tell me how to save????=?

  25. K FU B
    August 27th, 2019

    Taking the exam tomorrow. Just curious on the BGP simlet. Do you only have to mess with R1 config. Or are there errors that need correcting on the other Routers. Thanks in advance

  26. Chui
    August 28th, 2019

    @K FU B Godluck on exam.

  27. Anonymous
    September 6th, 2019

    Passed today with score 982. When i resolved the ibgp problem i had to reconfigure all Ibgp peer group. It don’t accept only the command neighbor IBGP remote-as 64520

  28. Anonymous
    September 6th, 2019

    echec today 835 second time despite being a networkut member
    i wanted to do my own method that’s the cause ..
    I will advise you to follow the sam methodology
    3 ticket about miss. Atention the ticket is manifested around all the tiket so soyer on the ticket vrais it is.
    some new questions .. please update the networkut member. thank you and the lute continues

  29. Gigi
    September 7th, 2019

    ok i had this bgp lab few days ago.
    And i remember this:
    1. you can control only R1 (all other don’t have consoles)
    2. the idea is that you have to have a specific routing table that you need to achieve
    there were 5 routes and one of them it was ***** (the 4th one)
    other 4 were /32 the loopbacks but they were learned somehow via external bgp i guess…
    3. two routes have local pref 100 the rest 0
    4. also there is a line missing in ibgp config something with selfnext hop
    That is all i can remember from this scenario

  30. Tshoot
    September 8th, 2019

    What command we have enter to go from R1# to R(config)#.
    I have tried enable and config t but it wouldn’t work.

  31. Anonymous
    September 12th, 2019

    Do we have to save the config after entering the commands?

  32. Nina
    September 13th, 2019

    Hello @Networktut, is the BGP simlet updated under Premium membership ? thanks!

  33. You’re Welcome
    September 13th, 2019

    BROKEN

    R1#sh ip bgp summary
    BGP router identifier 172.16.1.1, local AS number 64520

    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
    172.16.2.2 4 64550 0 0 1 0 0 never Idle
    172.16.3.3 4 64550 0 0 1 0 0 never Idle
    209.165.200.2 4 64525 0 0 1 0 0 never Idle

    R1#sh run | s router bgp
    router bgp 64520
    bgp log-neighbor-changes
    network 172.16.1.1 mask 255.255.255.255
    neighbor IBGP peer-group
    neighbor IBGP remote-as 64550
    neighbor IBGP update-source Loopback0
    neighbor IBGP next-hop-self
    neighbor 172.16.2.2 peer-group IBGP
    neighbor 172.16.3.3 peer-group IBGP
    neighbor 209.165.200.2 remote-as 64525

    R1#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    R1(config)#router bgp 64520

    FIX iBGP
    R1(config-router)#neighbor IBGP remote-as 64520
    R1(config-router)#
    *Sep 13 21:31:39.053: %BGP-5-ADJCHANGE: neighbor 172.16.3.3 Up
    R1(config-router)#
    *Sep 13 21:31:42.532: %BGP-5-ADJCHANGE: neighbor 172.16.2.2 Up

    FIX eBGP
    R1(config-router)#no neighbor 209.165.200.2 remote-as 64525
    R1(config-router)#neighbor 209.165.201.2 remote-as 64525
    R1(config-router)#
    *Sep 13 21:32:20.920: %BGP-5-ADJCHANGE: neighbor 209.165.201.2 Up
    R1(config-router)#exit
    R1(config)#exit

    FIXED

    R1#sh run | s router bgp
    router bgp 64520
    bgp log-neighbor-changes
    network 172.16.1.1 mask 255.255.255.255
    neighbor IBGP peer-group
    neighbor IBGP remote-as 64520
    neighbor IBGP update-source Loopback0
    neighbor IBGP next-hop-self
    neighbor 172.16.2.2 peer-group IBGP
    neighbor 172.16.3.3 peer-group IBGP
    neighbor 209.165.201.2 remote-as 64525

    R1#sh ip bgp summary
    BGP router identifier 172.16.1.1, local AS number 64520

    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
    172.16.2.2 4 64520 8 2 1 0 0 00:00:48 3
    172.16.3.3 4 64520 6 2 1 0 0 00:00:52 1
    209.165.201.2 4 64525 6 2 1 0 0 00:00:10 2

    R1#sh ip route

    192.168.1.0/32 is subnetted, 1 subnets
    B 192.168.1.1 [20/0] via 209.165.201.2, 00:01:29
    192.168.2.0/32 is subnetted, 1 subnets
    B 192.168.2.2 [20/0] via 209.165.201.2, 00:01:29

  34. savafa80
    September 17th, 2019

    Tks @You’re Welcome by your explanation

  35. PAT
    September 26th, 2019

    If anyone have CCNP tshoot latest dumps. Please share with me My Email Id is sahaayushioe @ gmail.com

  36. mrchavezj
    September 30th, 2019

    Hello everyone! If anyone has CCNP tshoot latest dumps. Please share with me My Email Id is mr_chavezj @ gmail.com no spaces. Thanks

  37. RJ
    October 2nd, 2019

    I Passed with 903, labs valid…some questions about vpn, security, spann three tunnel GRE, i did not study

  38. PR
    October 7th, 2019

    Thanks RJ – Can you comment on Trouble Ticket and LABS are all same ?what exactly has changed? Which dumps should i prepare for exam as i am going for exam this week

  39. Answer Correcting
    October 7th, 2019

    config t
    router bgp 64520
    no IBGP remote-as 64550
    no neighbor 209.165.200.2 remote-as 64525
    neighbor IBGP remote-as 64525
    neighbor 172.16.2.2 peer-group IBGP
    neighbor 172.16.3.3 peer-group IBGP
    neighbor 209.165.201.2 remote-as 64525

  40. I made mistake. on IGP ASN
    October 7th, 2019

    config t
    router bgp 64520
    no IBGP remote-as 64550
    no neighbor 209.165.200.2 remote-as 64525
    neighbor IBGP remote-as 64520
    neighbor 172.16.2.2 peer-group IBGP
    neighbor 172.16.3.3 peer-group IBGP
    neighbor 209.165.201.2 remote-as 64525

  41. IOU HELP
    October 17th, 2019

    CAN YOU FACILITATE THE MOST CURRENT IOU?

  42. julius
    October 23rd, 2019

    Hi,

    Please tell me if it is okay if I just configure what is given by networktut in this BGP Sims? Will I get a perfect score?

    R1(config)#router bgp 64520
    R1(config-router)#neighbor IBGP remote-as 64520
    R1(config-router)#no neighbor 209.165.200.2 remote-as 64525
    R1(config-router)#neighbor 209.165.201.2 remote-as 64525

    Thanks in Advance.

  43. Janko
    October 23rd, 2019

    Hi All,

    i just passed today and had this BGP Simlet. In instructions i had info to not change anything about neighbor IBGP peer-group, so all i did is:

    R1(config)#router bgp 64520
    R1(config-router)#neighbor IBGP remote-as 64520
    R1(config-router)#no neighbor 209.165.221.2 remote-as 64525
    R1(config-router)#neighbor 209.165.201.2 remote-as 64525

    There is no need to save config as it’s not working + all you need to check then is show ip bgp.
    If you would like to see your neighbors just issue command show ip bgp summary

  44. julius
    October 24th, 2019

    @Janko

    Thanks for the hep!

  45. Anon Pass
    October 31st, 2019

    Took the test today. BGP sim was exactly as described. I was able to just type the new peer-group command without ‘no’-ing it first. I did a ‘no neighbor’ on the eBGP neighbor IP and got the expected results.

  46. Hara
    November 12th, 2019

    Hi, is the BGP sim still like you choose the answer from the options like the ticket? Or is it something that you input exact commands?

  47. Dave
    November 16th, 2019

    There is only 1 possible Sim in the exam at the moment?

Comment pages
1 4 5 6 993