Home > Ticket 13 – DHCP Helper-address

Ticket 13 – DHCP Helper-address

April 24th, 2018 in TSHOOT v2 Go to comments

Configuration on DSW1:

!
interface Vlan 10
 ip address 10.2.1.1 255.255.255.0
 ip helper-address 10.2.21.129
!

Note: In this ticket you will find port-security configured on ASW1 but it is not the problem as the port-security is good (check with the “show interface fa1/0/1” command on ASW1. Also if we use “ipconfig” command on Client1, we will see APIPA address (169.254.x.x).

Ans1) DSW1
Ans2) IP DHCP Server (or DHCP)
Ans3) on DSW1 delete “ip helper-address 10.2.21.129” and apply “ip helper-address 10.1.21.129” command

Comments (41) Comments
Comment pages
1 4 5 6 211
  1. Anonymous
    November 18th, 2017

    Can anyone explain why helper address is 10.1.21.129 ?

  2. Anonymous
    November 19th, 2017

    this question is still valid as of today

  3. gs
    November 21st, 2017

    10.1.21.129 is the Lo1 address on R4.

  4. failed-test
    November 23rd, 2017

    This question is valid. However the Clients are assigned an IP (which in real life they shouln’t) which may cause this question to throw you off balance.

  5. GATA
    December 1st, 2017

    I didn’t get this one

  6. G-unit
    December 11th, 2017

    The clients actually get an APIPA address 169.254.x.x.

  7. Just_passed
    December 13th, 2017

    Confirmed, clients get 169.254.x.x addresses now

  8. Gav
    December 27th, 2017

    **@NetworkTUT or anyone who could answer –**

    Could someone please advise how we get to know from config that DHCP is with IP 10.1.21.129?
    I have my exam day after tomorrow so would appreciate prompt response

  9. Gav
    December 28th, 2017

    Guys – could anyone please respond to my question above – its urgent

    Question is:
    Could someone please advise how we get to know from config that DHCP is with IP 10.1.21.129?

    In exam – IPs etc would change and there is no mention anywhere that loopback on R4 is the DHCP server IP. So my question is – how would we know in exam what interface is going to be used as DHCP server

    Kindly assist
    Gav

  10. NotYou
    December 28th, 2017

    @Gav. The topology has an arrow pointing out R4 is DHCP. R4 has DHCP configuration. In show run, it shows a description on Lo1 that it is Helper Loopback

  11. Fattah RazzaqghanimughnI
    January 4th, 2018

    Silly…. I spent unnecessary time to troubleshoot the Sim Labs from networktut.com which is not even mentioned in the question. This sim have soooo many problems which are not stated in this page:

    1) EIGRP continues to sending routing updates from DSW1 and DSW2 on VLAN20 via ASW2, therefore, under “router eigrp 10” we need to enter command “passive-interface Vlan20” both in DSW1 and DSW2.

    2) Client1 and Client2 will never get DHCP IP ever, ever, never, because in R4 thereare exclusion command line “ip dhcp excluded-address 10.2.1.1 10.2.1.253”, we need to delete this line by entering command in global configuration mode “no ip dhcp excluded-address 10.2.1.1 10.2.1.253”, and change it with another command line “ip dhcp excluded-address 10.2.1.1 10.2.1.2″

    3) There are line ” mac-address 00e0.a3e3.3901″ under “interface Vlan10” on DSW1, I don’t know what is this effect to, but I can not remove this line.

    At last, I set static IP in Client1 and now it can ping the webserver 209.65.200.241.

    I’ve paid for premium membership, and well, in the premium the tickets are in different order.

  12. Fattah RazzaqghanimughnI
    January 4th, 2018

    Silly…. I spent unnecessary time to troubleshoot the Sim Labs from networktut.com which is not even mentioned in the question. This sim have soooo many problems which are not stated in this page:

    1) EIGRP continues to sending routing updates from DSW1 and DSW2 on VLAN20 via ASW2, therefore, under “router eigrp 10” we need to enter command “passive-interface Vlan20” both in DSW1 and DSW2.

    2) Client1 and Client2 will never get DHCP IP ever, ever, never, because in R4 thereare exclusion command line “ip dhcp excluded-address 10.2.1.1 10.2.1.253”, we need to delete this line by entering command in global configuration mode “no ip dhcp excluded-address 10.2.1.1 10.2.1.253”, and change it with another command line “ip dhcp excluded-address 10.2.1.1 10.2.1.2″

    3) There is no DHCP IP Pool configured yet. We have to create it our own. From global configuration mode enter “ip dhcp pool VLAN_10_CLIENTS”, enter “network 10.2.1.0 255.255.255.0”, enter “default-router 10.2.1.254”

    And there you go, Client1 and Client2 can acquired DHCP IP and now they can ping the webserver 209.65.200.241.

    I’ve paid for premium membership, and well, in the premium the tickets are in different order.

  13. Integrals
    January 8th, 2018

    @ Gav
    @ NotYou

    The Questions clearly says, “The client workstations receive their IP address and default gateway via R4’s DHCP server”

    So, it is safe to assume that R4 is the DHCP Server.

    But as NotYou says, when I do a show run in R4, it is not showing the description ‘Helper’ anywhere. Not under the Loopback 1 interface, and not under the DHCP configuration either

    So, I am not sure how to identify which interface is gonna act as the DHCP Server in case if it is a different IP Address.

    @ Networktut, any suggestions?

  14. Mangal76
    January 10th, 2018

    If you go back few pages some one has actually answered this however here is my understanding of it.

    if you look at the top of this page where the answer is shown, it does tell you that DSW1 is where the helper is located. When you do “Show run” helper ip will show up under “Interface Vlan 10”. In the real exam, look at the topology and it will eventually tell you where the clients are getting their IP addresses from. This should be in the scenario section if not just type the command ipconfig on one of the clients to see which is the DHCP server.

    Once you locate the DHCP server (R4 in network tut ticket) than do “show run” or “show ip interface Loopback1” to find out the ip address and cross check if the Helper address IP on DSW1 and Loopback1 ip address is identical. if not you found the issue.

    I hope this helps.

  15. Abdul Ghafoor
    January 11th, 2018

    For GAV and GATA
    I hope you understand this ticket by now, Mangal76 explained it very well.
    Just in case, let me explain this again from a different angle.

    If you look at IPv4 Layer 3 Topology, you will notice that DHCP Server is on the R4. Hence the address of DHCP Server must be loopback address of R4. You must call it on the Distribution Switch/Router (DSW1) as a ip-helper address so it knows where to pull ip addresses for the devices, i.e. PC (Client 1).

    I hope this helps.

  16. Anonymous
    January 17th, 2018

    packet capture started working for me after i updated the helper address 10.1.4.5

  17. TShoot attendee
    January 20th, 2018

    I am planning to take my Tshoot on 22nd Jan. In preperation for the exam. What Mangal76 has shared is very correct. On R4 which is the GW device we can see the DHCP Helper address that is to be compared on DSW1. In this case DSW1 and DSW2 can be the helper device for the clients.

  18. Test
    January 27th, 2018

    Okay which device actually has the issue in this ticket ?

    R4 or DSW 1

    The packet tracer says R4 and here it says DSW1

  19. T5 Ccnp
    January 29th, 2018

    dear all,

    the real problem about IP helper that in Packet tracer (or exam i did not take it yet.) its must add in all devices that from DSW1 to Client.
    DSW1 is already setup
    but
    ASW1 is not

    when i add that commend on ASW1 and under inter vlan 10
    all host got IP from DHCP(R4)

  20. wipward
    February 12th, 2018

    Deal all,
    if you are practicing through packet-tracer you will find out that the helper address is correct on DSW switches, but on R4 they are excluding the whole subnet from the DHCP.

    ip dhcp excluded-address 10.2.1.254
    ip dhcp excluded-address 10.2.1.1 10.2.1.253

    that’s why the PC is not able to get an IP address from the DHCP router.
    remove the exclude “ip dhcp excluded-address 10.2.1.1 10.2.1.253” using the no command.
    and add “ip dhcp excluded-address 10.2.1.1 10.2.1.10” to exclude the first ten ip addresses.
    at this stage the PC will be able to get an IP.

  21. saf
    February 12th, 2018

    plz explain problem is on r4 ordsw!..i am confused what is the right answer..

  22. Vahn
    February 14th, 2018

    @Saf answer is correct. in DSW1, correct the ip helper to have 10.1.21.129 instead of it’s old one. as 10.1.21.129 is the loopback address of R4, which is their DHCP server (as stated on IPv4 Layer 3 Topology)

  23. Helper
    March 5th, 2018

    Hello guys. I was just approved on the exam and there is something you must pay attention regarding this question. The ip helper address appears almost on the bottom of the DSW1 “sh run” outputs, a bit differently from the networktut labs and if you go to thevASW1, there is a port security issue so that you might be confused. So, scroll down to see if you find the configs from VLAN 10 with the wrong ip helper address, and if there is a MAC address captured by port security on ASW1, check again the DSW1 to see if you accidentally did not skip the wrong up helper address. Note: te Mac actress captured on asw1 is not 0000.0000.0001. It aí different. I recommend to study using the premium labs from networktut. It is really close from you will face on the exam. Also, do de exam calmly and paying attention to what you are choosing.

  24. ROADTONP
    March 8th, 2018

    Hey Guys, I read from the home page that Client hosts have statically assigned IP addresses. Does anybody know if this is applicable to the DHCP sim? If what networktut has advised is correct, there would no be problem connecting from the Client hosts to the Server would there?

  25. Anonymous
    March 29th, 2018

    After making configuration changes, save copy run start or wr mem and reload the device.
    I noticed that after adding ipv6 osfp are 0, ipv6 neighbors won’t come up, only if the r2 is relaoded.

  26. Anonymous
    March 30th, 2018

    Network tut why the f–ck you are providing fu–ed up configurations?
    Some of the ticket are just a waste of time, couldn’t you just eliminate the ip pool restrictions and provide a config with wrong ip helper to be changes?
    This is madness and we all pay for …hmmmm what is the quality of the information provided, must likely I will ask for money money back!!

  27. networktut
    March 31st, 2018

    @Anonymous: There is nothing wrong with the ip pool in this ticket so we should not remove it.

  28. Anon
    April 10th, 2018

    If we use the lo 21 on R4 this works fine for ip helper. But also why can we not use interface fa/1 10.1.4.5 on R1 as this is reachable from ASW1. I am trying this as test but clients not receiving ip address from pool

  29. Anon
    April 10th, 2018

    use interface fa/1 10.1.4.5 on R4… Apologies

  30. Confuse guy
    April 11th, 2018

    @Fattah RazzaqghanimughnI J

    3) There are line ” mac-address 00e0.a3e3.3901″ under “interface Vlan10” on DSW1, I don’t know what is this effect to, but I can not remove this line.

    this is command to confiure hrsp mac address right

  31. Confuse guy
    April 11th, 2018

    Just my 2 cents,

    Ip helper address is DHCP RELAY, not the DHCP SERVER .

    So definitely helper should be in DSW1 in this case

  32. HiTmAn47
    April 18th, 2018

    Can Someone explain to me how you knew the DHCP server is loopback 1 …. and why you didn’t assume it’s loopback 0 ….. I know the question states that the server is on R4 …. but how you know which loopback is the server ?

  33. CCNP2K
    April 23rd, 2018

    What is the exact question on this ticket?

  34. Sez
    May 11th, 2018

    I would like to give you a tip about Ticket 13. I have passed my exam today(11.05.2018)
    This question is a little bit confusing with port security but what I have done that check the mac address table of SW1 and it was right.
    But I wasn’t still sure that it was port security or IP Helper address problem.
    at the end i have found the solution.
    I have check the DSW2 configuration(show run) and compare with DSW1
    DSW1 show the IP helper address :10.2.21.129
    DSW2 show the IP helper address : 10.1.21.129
    Then I was sure that it’s IP-Helper address problem.

  35. Alex
    May 18th, 2018

    @Sez

    wow! what a genius!

  36. npall
    May 23rd, 2018

    @networktut in Ticket 13 there is a note as below
    “Also you can easily identify this ticket with the “ipconfig” command on Client1, which shows APIPA address (169.254.x.x). ”

    This is quite misleading since Ticket number 9 client 1 ipconfig also shows 169.254.X.X

    Please check and let me know if im mistaken with my observation. Thanx

  37. networktut
    May 23rd, 2018

    @npall: Yes, it is misleading so we have just updated it. Thanks for your detection!

  38. 54547sdfsd
    May 24th, 2018

    Passed my exam today.
    Everything here is valid.

    stumbleupon.com/su/2aNkAM

    Thank you

  39. Ronald
    May 28th, 2018

    For this ticket:
    Configuration of ASW1
    interface fa1/0/1
    switchport access vlan 10
    switchport mode access
    switchport port-security
    switchport port-security mac-address 0000.0000.0001

    Is this wrong?
    how is this ticket different to Ticket 7?

  40. dhcp ticket
    June 6th, 2018

    guys this ticket is dhcp ticket not gre tunnel ticket

  41. X
    June 8th, 2018

    Thank you for your comments team.

    To verify if this is a DHCP herlper issue, the only thing we need to do is very that the interface vlan 10 on DSW1 and DSW2 has the same command (ip helper-address 10.1.21.129), if it is ok we may review the DHCP server config which is R4 as ‘wipward’ said:

    “if you are practicing through packet-tracer you will find out that the helper address is correct on DSW switches, but on R4 they are excluding the whole subnet from the DHCP.

    ip dhcp excluded-address 10.2.1.254
    ip dhcp excluded-address 10.2.1.1 10.2.1.253

    that’s why the PC is not able to get an IP address from the DHCP router.
    remove the exclude “ip dhcp excluded-address 10.2.1.1 10.2.1.253” using the no command.
    and add “ip dhcp excluded-address 10.2.1.1 10.2.1.10” to exclude the first ten ip addresses.
    at this stage the PC will be able to get an IP.”

    Thank you.

Comment pages
1 4 5 6 211